Citrix ICA Client Quits During Signon

Overview

A recent Microsoft update to the Windows Remote Desktop (RDP) client may give some of our clients with older ICA clients issues trying to connect to our servers. This update, version 6.0, was included automatically in a patch set from Microsoft, and is being distributed to our clients PC's in the field via Microsoft's Windows Update service.

Symptoms

Affected machines may see the usual Citrix login screen disappear on its own, usually after seeing "Negotiating Capabilities" in the Citrix dialog box.

Cause

The issue has to do with Windows registry permissions that the ICA client is expecting to see. The Microsoft RDP Client update changed permissions on a registry key that the ICA client was expecting to have access to, which causes the program to fail. The registry key is used by the ICA Client to verify licensing information for the connection. Without a valid license, the connection is halted, and the client disappears without warning.

This primarily affects users with ICA clients before version 9.0; later versions do not use the Windows Registry key in the same way that older versions did.

Resolution

  1. Update your ICA Client software to the latest release. This is available for free from our Download Center.
  2. Follow the instructions below to remove the incorrectly permissioned license key from the Windows Registry.

WARNING :
Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows. HAI cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. If possible, please contact your IT staff to assist you with this procedure.

  1. From the Windows Start Menu, click "Start", "Run".
  2. Type "regedit". Click "OK".
  3. Navigate the tree menu to the following key :
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing\Store\
  4. Locate the License Key. Most likely, there will be only one, called "LICENSE000". If you have other Citrix servers that you use regularly, there could be more; consult your Citrix staff if this is the case before proceeding
  5. Right click on the license key "LICENSE000", and click "Delete". Confirm by clicking "OK".
  6. Close regedit.
  7. Return to your normal application launch page, and try signing on again. The server should issue a new license, which the client will write to the registry with correct permissions, and you should see a Windows logon screen.
Last Reviewed:
Feburary 15, 2007
Questions?
Please contact HAI Technical Support for more information.